What’s Vulnerable › Vulnerabilities

CVE-2023-34141

Description

A command injection vulnerability in the access point (AP) management feature of the Zyxel ATP series firmware versions 5.00 through 5.36 Patch 2, USG FLEX series firmware versions 5.00 through 5.36 Patch 2, USG FLEX 50(W) series firmware versions 5.00 through 5.36 Patch 2, USG20(W)-VPN series firmware versions 5.00 through 5.36 Patch 2, VPN series firmware versions 5.00 through 5.36 Patch 2, NXC2500 firmware versions 6.10(AAIG.0) through 6.10(AAIG.3), and NXC5500 firmware versions 6.10(AAOS.0) through 6.10(AAOS.4), could allow an unauthenticated, LAN-based attacker to execute some OS commands on an affected device if the attacker could trick an authorized administrator to add their IP address to the managed AP list in advance.

Affected products

How to fix

Upgrade to a fixed version: Zyxel USG 20(W)-VPN firmware 5.37; Zyxel Usg 2200-Vpn Firmware 5.37; Zyxel firewall (ZLD) 5.37; Zyxel USG FLEX 100(W) firmware 5.37; Zyxel USG FLEX 200 firmware 5.37; Zyxel USG FLEX 500 firmware 5.37; Zyxel Usg Flex 50 Firmware 5.37; Zyxel USG FLEX 50(W) firmware 5.37; Zyxel USG FLEX 700 firmware 5.37; Zyxel Zywall Atp100 Firmware 5.37; Zyxel Zywall Atp100W Firmware 5.37; Zyxel Zywall Atp200 Firmware 5.37. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-34141 or the next vulnerability affects your stack