What’s Vulnerable › Vulnerabilities
CVE-2023-34149: Apache Struts: DoS via OOM owing to not properly checking of list bounds
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-14 · updated 2026-06-17
- Weakness: CWE-770
Description
Allocation of Resources Without Limits or Throttling vulnerability in Apache Software Foundation Apache Struts.This issue affects Apache Struts: through 2.5.30, through 6.1.2. Upgrade to Struts 2.5.31 or 6.1.2.1 or greater.
Affected products
- Apache Struts: before 2.5.31; from 6.0.0 before 6.1.2.1 — fixed in 2.5.31, 6.1.2.1
How to fix
Upgrade to a fixed version: Apache Struts 2.5.31, 6.1.2.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/06/14/2
- https://cwiki.apache.org/confluence/display/WW/S2-063
- https://security.netapp.com/advisory/ntap-20230706-0005/
- http://www.openwall.com/lists/oss-security/2023/06/14/2
- https://cwiki.apache.org/confluence/display/WW/S2-063
- https://security.netapp.com/advisory/ntap-20230706-0005/
Get alerted when CVE-2023-34149 or the next vulnerability affects your stack