What’s Vulnerable › Vulnerabilities
CVE-2023-34188
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-1284
Description
The HTTP server in Mongoose before 7.10 accepts requests containing negative Content-Length headers. By sending a single attack payload over TCP, an attacker can cause an infinite loop in which the server continuously reparses that payload, and does not respond to any other requests.
Affected products
- Cesanta Mongoose: before 7.10 — fixed in 7.10
How to fix
Upgrade to a fixed version: Cesanta Mongoose 7.10. Check the vendor advisory for mitigations.
References
- https://blog.narfindustries.com/blog/narf-discovers-critical-vulnerabilities-in-cesanta-mongoose-http-server
- https://github.com/cesanta/mongoose/commit/4663090a8fb036146dfe77718cff612b0101cb0f
- https://github.com/cesanta/mongoose/compare/7.9...7.10
- https://github.com/cesanta/mongoose/pull/2197
- https://blog.narfindustries.com/blog/narf-discovers-critical-vulnerabilities-in-cesanta-mongoose-http-server
- https://github.com/cesanta/mongoose/commit/4663090a8fb036146dfe77718cff612b0101cb0f
- https://github.com/cesanta/mongoose/compare/7.9...7.10
- https://github.com/cesanta/mongoose/pull/2197
- https://security.netapp.com/advisory/ntap-20250228-0001/
Get alerted when CVE-2023-34188 or the next vulnerability affects your stack