What’s Vulnerable › Vulnerabilities
CVE-2023-34203
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-74
Description
In Progress OpenEdge OEM (OpenEdge Management) and OEE (OpenEdge Explorer) before 12.7, a remote user (who has any OEM or OEE role) could perform a URL injection attack to change identity or role membership, e.g., escalate to admin. This affects OpenEdge LTS before 11.7.16, 12.x before 12.2.12, and 12.3.x through 12.6.x before 12.7.
Affected products
- Progress Software Corporation OpenEdge: before 11.7.16; from 12.0 before 12.2.12; from 12.3 before 12.7 — fixed in 11.7.16, 12.2.12, 12.7
- Progress Openedge Explorer: before 12.7 — fixed in 12.7
- Progress Openedge Management: before 12.7 — fixed in 12.7
How to fix
Upgrade to a fixed version: Progress Software Corporation OpenEdge 11.7.16, 12.2.12, 12.7; Progress Openedge Explorer 12.7; Progress Openedge Management 12.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-34203 or the next vulnerability affects your stack