What’s Vulnerable › Vulnerabilities
CVE-2023-34232: Snowflake NodeJS Driver vulnerable to Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-08 · updated 2026-06-17
- Weakness: CWE-77
Description
snowflake-connector-nodejs, a NodeJS driver for Snowflake, is vulnerable to command injection via single sign on (SSO) browser URL authentication in versions prior to 1.6.21. In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Version 1.6.21 contains a patch for this issue.
Affected products
- snowflakedb snowflake-connector-python: before 1.6.21 — fixed in 1.6.21
How to fix
Upgrade to a fixed version: snowflakedb snowflake-connector-python 1.6.21. Check the vendor advisory for mitigations.
References
- https://community.snowflake.com/s/article/Node-js-Driver-Release-Notes
- https://github.com/snowflakedb/snowflake-connector-nodejs/commit/0c9622ae12cd7d627df404b73a783b4a5f60728a
- https://github.com/snowflakedb/snowflake-connector-nodejs/pull/465
- https://github.com/snowflakedb/snowflake-connector-nodejs/security/advisories/GHSA-h53w-7qw7-vh5c
- https://community.snowflake.com/s/article/Node-js-Driver-Release-Notes
- https://github.com/snowflakedb/snowflake-connector-nodejs/commit/0c9622ae12cd7d627df404b73a783b4a5f60728a
- https://github.com/snowflakedb/snowflake-connector-nodejs/pull/465
- https://github.com/snowflakedb/snowflake-connector-nodejs/security/advisories/GHSA-h53w-7qw7-vh5c
Get alerted when CVE-2023-34232 or the next vulnerability affects your stack