What’s Vulnerable › Vulnerabilities
CVE-2023-34233: Snowflake Python Connector vulnerable to Command Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-08 · updated 2026-06-17
- Weakness: CWE-77
Description
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Versions prior to 3.0.2 are vulnerable to command injection via single sign-on(SSO) browser URL authentication. In order to exploit the potential for command injection, an attacker would need to be successful in (1) establishing a malicious resource and (2) redirecting users to utilize the resource. The attacker could set up a malicious, publicly accessible server which responds to the SSO URL with an attack payload. If the attacker then tricked a user into visiting the maliciously crafted connection URL, the user’s local machine would render the malicious payload, leading to a remote code execution. This attack scenario can be mitigated through URL whitelisting as well as common anti-phishing resources. Version 3.0.2 contains a patch for this issue.
Affected products
- snowflakedb snowflake-connector-python: before 3.0.2 — fixed in 3.0.2
How to fix
Upgrade to a fixed version: snowflakedb snowflake-connector-python 3.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/snowflakedb/snowflake-connector-python/commit/1cdbd3b1403c5ef520d7f4d9614fe35165e101ac
- https://github.com/snowflakedb/snowflake-connector-python/pull/1480
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-5w5m-pfw9-c8fp
- https://github.com/snowflakedb/snowflake-connector-python/commit/1cdbd3b1403c5ef520d7f4d9614fe35165e101ac
- https://github.com/snowflakedb/snowflake-connector-python/pull/1480
- https://github.com/snowflakedb/snowflake-connector-python/security/advisories/GHSA-5w5m-pfw9-c8fp
Get alerted when CVE-2023-34233 or the next vulnerability affects your stack