What’s Vulnerable › Vulnerabilities
CVE-2023-34234: Governor proposal creation may be blocked by frontrunning in OpenZeppelin
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-862
Description
OpenZeppelin Contracts is a library for smart contract development. By frontrunning the creation of a proposal, an attacker can become the proposer and gain the ability to cancel it. The attacker can do this repeatedly to try to prevent a proposal from being proposed at all. This impacts the `Governor` contract in v4.9.0 only, and the `GovernorCompatibilityBravo` contract since v4.3.0. This problem has been patched in 4.9.1 by introducing opt-in frontrunning protection. Users are advised to upgrade. Users unable to upgrade may submit the proposal creation transaction to an endpoint with frontrunning protection as a workaround.
Affected products
- openzeppelin-contracts: from 4.3.0 before 4.9.1 — fixed in 4.9.1
- OpenZeppelin Contracts Upgradeable: from 4.3.0 before 4.9.1 — fixed in 4.9.1
How to fix
Upgrade to a fixed version: openzeppelin-contracts 4.9.1; OpenZeppelin Contracts Upgradeable 4.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/d9474327a492f9f310f31bc53f38dbea56ed9a57
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5h3x-9wvq-w4m2
- https://github.com/OpenZeppelin/openzeppelin-contracts/commit/d9474327a492f9f310f31bc53f38dbea56ed9a57
- https://github.com/OpenZeppelin/openzeppelin-contracts/security/advisories/GHSA-5h3x-9wvq-w4m2
Get alerted when CVE-2023-34234 or the next vulnerability affects your stack