What’s Vulnerable › Vulnerabilities
CVE-2023-34237: Remote code execution via specially crafted script settings in SABnzbd
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-07 · updated 2026-06-17
- Weakness: CWE-94
Description
SABnzbd is an open source automated Usenet download tool. A design flaw was discovered in SABnzbd that could allow remote code execution. Manipulating the Parameters setting in the Notification Script functionality allows code execution with the privileges of the SABnzbd process. Exploiting the vulnerabilities requires access to the web interface. Remote exploitation is possible if users[exposed their setup to the internet or other untrusted networks without setting a username/password. By default SABnzbd is only accessible from `localhost`, with no authentication required for the web interface. This issue has been patched in commits `e3a722` and `422b4f` which have been included in the 4.0.2 release. Users are advised to upgrade. Users unable to upgrade should ensure that a username and password have been set if their instance is web accessible.
Affected products
- sabnzbd: from 1.1.0 before 4.0.2 — fixed in 4.0.2
How to fix
Upgrade to a fixed version: sabnzbd 4.0.2. Check the vendor advisory for mitigations.
References
- https://github.com/sabnzbd/sabnzbd/commit/422b4fce7bfd56e95a315be0400cdfdc585df7cc
- https://github.com/sabnzbd/sabnzbd/commit/e3a722664819d1c7c8fab97144cc299b1c18b429
- https://github.com/sabnzbd/sabnzbd/security/advisories/GHSA-hhgh-xgh3-985r
- https://sabnzbd.org/wiki/configuration/4.0/general
- https://security.gentoo.org/glsa/202312-11
- https://github.com/sabnzbd/sabnzbd/commit/422b4fce7bfd56e95a315be0400cdfdc585df7cc
- https://github.com/sabnzbd/sabnzbd/commit/e3a722664819d1c7c8fab97144cc299b1c18b429
- https://github.com/sabnzbd/sabnzbd/security/advisories/GHSA-hhgh-xgh3-985r
- https://sabnzbd.org/wiki/configuration/4.0/general
- https://security.gentoo.org/glsa/202312-11
Get alerted when CVE-2023-34237 or the next vulnerability affects your stack