What’s Vulnerable › Vulnerabilities
CVE-2023-34240: Weak passwords allowed in cloudexplorer-lite
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-27 · updated 2026-06-17
- Weakness: CWE-521
Description
Cloudexplorer-lite is an open source cloud software stack. Weak passwords can be easily guessed and are an easy target for brute force attacks. This can lead to an authentication system failure and compromise system security. Versions of cloudexplorer-lite prior to 1.2.0 did not enforce strong passwords. This vulnerability has been fixed in version 1.2.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- CloudExplorer-Dev CloudExplorer-Lite: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: CloudExplorer-Dev CloudExplorer-Lite 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-px4m-5j22-5mw4
- https://github.com/CloudExplorer-Dev/CloudExplorer-Lite/security/advisories/GHSA-px4m-5j22-5mw4
Get alerted when CVE-2023-34240 or the next vulnerability affects your stack