What’s Vulnerable › Vulnerabilities
CVE-2023-34244: GLPI vulnerable to reflected XSS in search pages
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-05 · updated 2026-06-17
- Weakness: CWE-79
Description
GLPI is a free asset and IT management software package. Starting in version 9.4.0 and prior to version 10.0.8, a malicious link can be crafted by an unauthenticated user that can exploit a reflected XSS in case any authenticated user opens the crafted link. Users should upgrade to version 10.0.8 to receive a patch.
Affected products
- glpi-project glpi: from 9.4.0 before 10.0.8 — fixed in 10.0.8
How to fix
Upgrade to a fixed version: glpi-project glpi 10.0.8. Check the vendor advisory for mitigations.
References
- https://github.com/glpi-project/glpi/releases/tag/10.0.8
- https://github.com/glpi-project/glpi/security/advisories/GHSA-p93p-pwg9-w95w
- https://github.com/glpi-project/glpi/releases/tag/10.0.8
- https://github.com/glpi-project/glpi/security/advisories/GHSA-p93p-pwg9-w95w
Get alerted when CVE-2023-34244 or the next vulnerability affects your stack