What’s Vulnerable › Vulnerabilities
CVE-2023-34246: Doorkeeper Improper Authentication vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-12 · updated 2026-06-17
- Weakness: CWE-287
Description
Doorkeeper is an OAuth 2 provider for Ruby on Rails / Grape. Prior to version 5.6.6, Doorkeeper automatically processes authorization requests without user consent for public clients that have been previous approved. Public clients are inherently vulnerable to impersonation, their identity cannot be assured. This issue is fixed in version 5.6.6.
Affected products
- doorkeeper-gem doorkeeper: before 5.6.6 — fixed in 5.6.6
- Rubygems Doorkeeper: before 5.6.6; 0.1.0, 0.1.1, 0.2.0, 0.3.0, 0.3.1, 0.3.2 (+108) — fixed in 5.6.6
How to fix
Upgrade to a fixed version: doorkeeper-gem doorkeeper 5.6.6; Rubygems Doorkeeper 5.6.6. Check the vendor advisory for mitigations.
References
- https://github.com/doorkeeper-gem/doorkeeper/issues/1589
- https://github.com/doorkeeper-gem/doorkeeper/pull/1646
- https://github.com/doorkeeper-gem/doorkeeper/releases/tag/v5.6.6
- https://github.com/doorkeeper-gem/doorkeeper/security/advisories/GHSA-7w2c-w47h-789w
- https://lists.debian.org/debian-lts-announce/2023/07/msg00016.html
- https://www.rfc-editor.org/rfc/rfc8252#section-8.6
- https://github.com/doorkeeper-gem/doorkeeper/issues/1589
- https://github.com/doorkeeper-gem/doorkeeper/pull/1646
- https://github.com/doorkeeper-gem/doorkeeper/releases/tag/v5.6.6
- https://github.com/doorkeeper-gem/doorkeeper/security/advisories/GHSA-7w2c-w47h-789w
- https://lists.debian.org/debian-lts-announce/2023/07/msg00016.html
- https://lists.debian.org/debian-lts-announce/2024/12/msg00010.html
Get alerted when CVE-2023-34246 or the next vulnerability affects your stack