What’s Vulnerable › Vulnerabilities
CVE-2023-34249: benjjvi/PyBB may send unsanitized request to SQL database
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-13 · updated 2026-06-17
- Weakness: CWE-89
Description
benjjvi/PyBB is an open source bulletin board. Prior to commit dcaeccd37198ecd3e41ea766d1099354b60d69c2, benjjvi/PyBB is vulnerable to SQL Injection. This vulnerability has been fixed as of commit dcaeccd37198ecd3e41ea766d1099354b60d69c2. As a workaround, a user may be able to update the software manually to avoid this problem by sanitizing user queries to `BulletinDatabaseModule.py`.
Affected products
- benjjvi PyBB: before 0.1.0 — fixed in 0.1.0
How to fix
Upgrade to a fixed version: benjjvi PyBB 0.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/benjjvi/PyBB/commit/dcaeccd37198ecd3e41ea766d1099354b60d69c2
- https://github.com/benjjvi/PyBB/security/advisories/GHSA-5qrx-fgxq-95gg
- https://github.com/benjjvi/PyBB/commit/dcaeccd37198ecd3e41ea766d1099354b60d69c2
- https://github.com/benjjvi/PyBB/security/advisories/GHSA-5qrx-fgxq-95gg
Get alerted when CVE-2023-34249 or the next vulnerability affects your stack