What’s Vulnerable › Vulnerabilities
CVE-2023-34253: Grav vulnerable to Server-side Template Injection (SSTI) via Denylist Bypass
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-14 · updated 2026-06-17
- Weakness: CWE-184
Description
Grav is a flat-file content management system. Prior to version 1.7.42, the denylist introduced in commit 9d6a2d to prevent dangerous functions from being executed via injection of malicious templates was insufficient and could be easily subverted in multiple ways -- (1) using unsafe functions that are not banned, (2) using capitalised callable names, and (3) using fully-qualified names for referencing callables. Consequently, a low privileged attacker with login access to Grav Admin panel and page creation/update permissions is able to inject malicious templates to obtain remote code execution. A patch in version 1.7.42 improves the denylist.
Affected products
- getgrav grav: before 1.7.42 — fixed in 1.7.42
How to fix
Upgrade to a fixed version: getgrav grav 1.7.42. Check the vendor advisory for mitigations.
References
- https://github.com/getgrav/grav/blob/1.7.40/system/src/Grav/Common/Utils.php#L1952-L2190
- https://github.com/getgrav/grav/commit/71bbed12f950de8335006d7f91112263d8504f1b
- https://github.com/getgrav/grav/security/advisories/GHSA-j3v8-v77f-fvgm
- https://huntr.dev/bounties/3ef640e6-9e25-4ecb-8ec1-64311d63fe66/
- https://www.github.com/getgrav/grav/commit/9d6a2dba09fd4e56f5cdfb9a399caea355bfeb83
- https://github.com/getgrav/grav/blob/1.7.40/system/src/Grav/Common/Utils.php#L1952-L2190
- https://github.com/getgrav/grav/commit/71bbed12f950de8335006d7f91112263d8504f1b
- https://github.com/getgrav/grav/security/advisories/GHSA-j3v8-v77f-fvgm
- https://huntr.dev/bounties/3ef640e6-9e25-4ecb-8ec1-64311d63fe66/
- https://www.github.com/getgrav/grav/commit/9d6a2dba09fd4e56f5cdfb9a399caea355bfeb83
Get alerted when CVE-2023-34253 or the next vulnerability affects your stack