What’s Vulnerable › Vulnerabilities
CVE-2023-34285: NETGEAR RAX30 cmsCli_authenticate Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-121
Description
NETGEAR RAX30 cmsCli_authenticate Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR RAX30 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within a shared library used by the telnetd service, which listens on TCP port 23 by default. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-19918.
Affected products
- NETGEAR RAX30: before 1.0.11.96_2_hotfix — fixed in 1.0.11.96_2_hotfix
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.11.96_2_hotfix. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065696/RAX30-Firmware-Version-1-0-11-96-Hot-Fix
- https://www.zerodayinitiative.com/advisories/ZDI-23-839/
- https://kb.netgear.com/000065696/RAX30-Firmware-Version-1-0-11-96-Hot-Fix
- https://www.zerodayinitiative.com/advisories/ZDI-23-839/
Get alerted when CVE-2023-34285 or the next vulnerability affects your stack