What’s Vulnerable › Vulnerabilities
CVE-2023-34298: Pulse Secure Client SetupService Directory Traversal Local Privilege Escalation Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-22
Description
Pulse Secure Client SetupService Directory Traversal Local Privilege Escalation Vulnerability. This vulnerability allows local attackers to escalate privileges on affected installations of Pulse Secure Client. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability. The specific flaw exists within SetupService. The issue results from the lack of proper validation of a user-supplied path prior to using it in file operations. An attacker can leverage this vulnerability to escalate privileges and execute arbitrary code in the context of the service. Was ZDI-CAN-17687.
Affected products
- Ivanti Pulse Secure Desktop Client: before 9.1; 9.1-r15 — fixed in 9.1
- Ivanti Pulse Secure Installer Service: 9.1-r18.23345, 22.4.1439
- Ivanti Secure Access Client: 22.2-r1, 22.3-r1, 22.3-r2
How to fix
Upgrade to a fixed version: Ivanti Pulse Secure Desktop Client 9.1. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-23-858/
- https://www.zerodayinitiative.com/advisories/ZDI-23-858/
- https://forums.ivanti.com/s/article/CVE-2023-34298-Ivanti-Secure-Access-Client-local-privilege-escalation?language=en_US
Get alerted when CVE-2023-34298 or the next vulnerability affects your stack