What’s Vulnerable › Vulnerabilities
CVE-2023-34336
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-12 · updated 2026-06-17
- Weakness: CWE-120
Description
AMI BMC contains a vulnerability in the IPMI handler, where an attacker with the required privileges can cause a buffer overflow, which may lead to code execution, denial of service, or escalation of privileges.
Affected products
- AMI MegaRAC_SPx: from 12.0 before 12.7; from 13.0 before 13.5 — fixed in 12.7, 13.5
How to fix
Upgrade to a fixed version: AMI MegaRAC_SPx 12.7, 13.5. Check the vendor advisory for mitigations.
References
- https://9443417.fs1.hubspotusercontent-na1.net/hubfs/9443417/Security%20Advisories/AMI-SA-2023005.pdf
- https://9443417.fs1.hubspotusercontent-na1.net/hubfs/9443417/Security%20Advisories/AMI-SA-2023005.pdf
Get alerted when CVE-2023-34336 or the next vulnerability affects your stack