What’s Vulnerable › Vulnerabilities
CVE-2023-34395: Apache Airflow ODBC Provider: Remote code execution vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-27 · updated 2026-06-17
- Weakness: CWE-88
Description
Improper Neutralization of Argument Delimiters in a Command ('Argument Injection') vulnerability in Apache Software Foundation Apache Airflow ODBC Provider. In OdbcHook, A privilege escalation vulnerability exists in a system due to controllable ODBC driver parameters that allow the loading of arbitrary dynamic-link libraries, resulting in command execution. Starting version 4.0.0 driver can be set only from the hook constructor. This issue affects Apache Airflow ODBC Provider: before 4.0.0.
Affected products
- Apache Software Foundation Apache Airflow ODBC Provider: before 4.0.0 — fixed in 4.0.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow ODBC Provider 4.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/31713
- https://lists.apache.org/thread/l26yykftzbhc9tgcph8cso88bc2lqwwd
- https://github.com/apache/airflow/pull/31713
- https://lists.apache.org/thread/l26yykftzbhc9tgcph8cso88bc2lqwwd
Get alerted when CVE-2023-34395 or the next vulnerability affects your stack