What’s Vulnerable › Vulnerabilities
CVE-2023-34411
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-05 · updated 2026-06-17
- Weakness: CWE-611
Description
The xml-rs crate before 0.8.14 for Rust and Crab allows a denial of service (panic) via an invalid <! token (such as <!DOCTYPEs/%<!A nesting) in an XML document. The earliest affected version is 0.8.9.
Affected products
- Xml Library Project Xml Library: before 0.8.14 — fixed in 0.8.14
How to fix
Upgrade to a fixed version: Xml Library Project Xml Library 0.8.14. Check the vendor advisory for mitigations.
References
- https://github.com/00xc/xml-rs/commit/0f084d45aa53e4a27476961785f59f2bd7d59a9f
- https://github.com/netvl/xml-rs/commit/c09549a187e62d39d40467f129e64abf32efc35c
- https://github.com/netvl/xml-rs/compare/0.8.13...0.8.14
- https://github.com/netvl/xml-rs/pull/226
- https://github.com/00xc/xml-rs/commit/0f084d45aa53e4a27476961785f59f2bd7d59a9f
- https://github.com/netvl/xml-rs/commit/c09549a187e62d39d40467f129e64abf32efc35c
- https://github.com/netvl/xml-rs/compare/0.8.13...0.8.14
- https://github.com/netvl/xml-rs/pull/226
Get alerted when CVE-2023-34411 or the next vulnerability affects your stack