What’s Vulnerable › Vulnerabilities

CVE-2023-34442: Apache Camel JIRA: Temporary file information disclosure in Camel-Jira

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Software Foundation Apache Camel.This issue affects Apache Camel: from 3.X through <=3.14.8, from 3.18.X through <=3.18.7, from 3.20.X through <= 3.20.5, from 4.X through <= 4.0.0-M3. Users should upgrade to 3.14.9, 3.18.8, 3.20.6 or 3.21.0 and for users on Camel 4.x update to 4.0.0-M1

Affected products

How to fix

Upgrade to a fixed version: Apache Software Foundation Apache Camel 3.14.9, 3.18.8, 3.20.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-34442 or the next vulnerability affects your stack