What’s Vulnerable › Vulnerabilities
CVE-2023-34447: iTop XSS vulnerability on pages/UI.php
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-79
Description
iTop is an open source, web-based IT service management platform. Prior to versions 3.0.4 and 3.1.0, on `pages/UI.php`, cross site scripting is possible. This issue is fixed in versions 3.0.4 and 3.1.0.
Affected products
- Combodo iTop: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: Combodo iTop 3.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/Combodo/iTop/commit/519751faa10b2fc5b75ea4516a1b8ef13ca35b33
- https://github.com/Combodo/iTop/commit/b8f61362f570e1ef8127175331012b7fc8aba802
- https://github.com/Combodo/iTop/security/advisories/GHSA-6rfm-2rwg-mj7p
- https://github.com/Combodo/iTop/commit/519751faa10b2fc5b75ea4516a1b8ef13ca35b33
- https://github.com/Combodo/iTop/commit/b8f61362f570e1ef8127175331012b7fc8aba802
- https://github.com/Combodo/iTop/security/advisories/GHSA-6rfm-2rwg-mj7p
Get alerted when CVE-2023-34447 or the next vulnerability affects your stack