What’s Vulnerable › Vulnerabilities
CVE-2023-34478: Apache Shiro before 1.12.0, or 2.0.0-alpha-3, may be susceptible to a path traversal attack when used together with APIs or other web frameworks that route requests based on non-normalized requests.
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-24 · updated 2026-06-17
- Weakness: CWE-22
Description
Apache Shiro, before 1.12.0 or 2.0.0-alpha-3, may be susceptible to a path traversal attack that results in an authentication bypass when used together with APIs or other web frameworks that route requests based on non-normalized requests. Mitigation: Update to Apache Shiro 1.12.0+ or 2.0.0-alpha-3+
Affected products
- Apache Software Foundation Apache Shiro: before 1.12.0; 2.0.0-alpha1, 2.0.0-alpha2 — fixed in 1.12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Shiro 1.12.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/07/24/4
- https://lists.apache.org/thread/mbv26onkgw9o35rldh7vmq11wpv2t2qk
- https://security.netapp.com/advisory/ntap-20230915-0005/
- http://www.openwall.com/lists/oss-security/2023/07/24/4
- https://lists.apache.org/thread/mbv26onkgw9o35rldh7vmq11wpv2t2qk
- https://security.netapp.com/advisory/ntap-20230915-0005/
Get alerted when CVE-2023-34478 or the next vulnerability affects your stack