What’s Vulnerable › Vulnerabilities
CVE-2023-34980: QTS, QuTS hero
- Severity: high (CVSS 8.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-03-08 · updated 2026-06-17
- Weakness: CWE-78
Description
An OS command injection vulnerability has been reported to affect several QNAP operating system versions. If exploited, the vulnerability could allow authenticated administrators to execute commands via a network. We have already fixed the vulnerability in the following versions: QTS 4.5.4.2627 build 20231225 and later QuTS hero h4.5.4.2626 build 20231225 and later
Affected products
- QNAP QTS: from 4.5.1 before 4.5.4.2627; 4.5.4.2627 — fixed in 4.5.4.2627
- QNAP Systems Inc. QuTS hero: from h4.5.0 before h4.5.4.2626; h4.5.4.2626 — fixed in h4.5.4.2626
How to fix
Upgrade to a fixed version: QNAP QTS 4.5.4.2627; QNAP Systems Inc. QuTS hero h4.5.4.2626. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-24-12
- https://www.qnap.com/en/security-advisory/qsa-24-12
Get alerted when CVE-2023-34980 or the next vulnerability affects your stack