What’s Vulnerable › Vulnerabilities
CVE-2023-3499: Robo Gallery < 3.2.16 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-04 · updated 2026-06-17
Description
The Photo Gallery, Images, Slider in Rbs Image Gallery WordPress plugin before 3.2.16 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- robosoft Robo Gallery – Photo & Image Slider: before 3.2.16 — fixed in 3.2.16
How to fix
Upgrade to a fixed version: robosoft Robo Gallery – Photo & Image Slider 3.2.16. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/ea29413b-494e-410e-ae42-42f96284899c
- https://wpscan.com/vulnerability/ea29413b-494e-410e-ae42-42f96284899c
Get alerted when CVE-2023-3499 or the next vulnerability affects your stack