What’s Vulnerable › Vulnerabilities

CVE-2023-3500: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 10.0 before 16.0.8, all versions starting from 16.1 before 16.1.3, all versions starting from 16.2 before 16.2.2. A reflected XSS was possible when creating specific PlantUML diagrams that allowed the attacker to perform arbitrary actions on behalf of victims.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.0.8, 16.1.3, 16.2.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3500 or the next vulnerability affects your stack