What’s Vulnerable › Vulnerabilities
CVE-2023-35005: Apache Airflow: Information disclosure on configuration view
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-19 · updated 2026-06-17
- Weakness: CWE-200
Description
In Apache Airflow, some potentially sensitive values were being shown to the user in certain situations. This vulnerability is mitigated by the fact configuration is not shown in the UI by default (only if `[webserver] expose_config` is set to `non-sensitive-only`), and not all uncensored values are actually sentitive. This issue affects Apache Airflow: from 2.5.0 before 2.6.2. Users are recommended to update to version 2.6.2 or later.
Affected products
- Apache Airflow: from 2.5.0 before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: Apache Airflow 2.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/31788
- https://github.com/apache/airflow/pull/31820
- https://lists.apache.org/thread/o4f2cxh0054m9tlxpb81c1yhylor5gjd
- https://github.com/apache/airflow/pull/31788
- https://github.com/apache/airflow/pull/31820
- https://lists.apache.org/thread/o4f2cxh0054m9tlxpb81c1yhylor5gjd
Get alerted when CVE-2023-35005 or the next vulnerability affects your stack