What’s Vulnerable › Vulnerabilities
CVE-2023-3501: FormCraft < 1.2.7 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-30 · updated 2026-06-17
Description
The FormCraft WordPress plugin before 1.2.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Formcrafts Formcraft: before 1.2.7 — fixed in 1.2.7
How to fix
Upgrade to a fixed version: Formcrafts Formcraft 1.2.7. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d3fb4a2b-ed51-4654-b7c1-4b0f59cd1ecf
- https://wpscan.com/vulnerability/d3fb4a2b-ed51-4654-b7c1-4b0f59cd1ecf
Get alerted when CVE-2023-3501 or the next vulnerability affects your stack