What’s Vulnerable › Vulnerabilities
CVE-2023-35049: WordPress WooCommerce Stripe Payment Gateway plugin <= 7.4.0 - Unauthenticated Broken Access Control vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-19 · updated 2026-06-17
- Weakness: CWE-862
Description
Missing Authorization vulnerability in WooCommerce WooCommerce Stripe Payment Gateway.This issue affects WooCommerce Stripe Payment Gateway: from n/a through 7.4.0.
Affected products
- WooCommerce Stripe Payment Gateway: before 7.4.1 — fixed in 7.4.1
How to fix
Upgrade to a fixed version: WooCommerce Stripe Payment Gateway 7.4.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woocommerce-gateway-stripe/wordpress-woocommerce-stripe-payment-gateway-plugin-7-4-0-unauthenticated-broken-access-control-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woocommerce-gateway-stripe/wordpress-woocommerce-stripe-payment-gateway-plugin-7-4-0-unauthenticated-broken-access-control-vulnerability?_s_id=cve
Get alerted when CVE-2023-35049 or the next vulnerability affects your stack