What’s Vulnerable › Vulnerabilities
CVE-2023-3507: WooCommerce Pre-Orders < 2.0.3 - Arbitrary Pre-Order Canceling via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-31 · updated 2026-06-17
Description
The WooCommerce Pre-Orders WordPress plugin before 2.0.3 has a flawed CSRF check when canceling pre-orders, which could allow attackers to make logged in admins cancel arbitrary pre-orders via a CSRF attack
Affected products
- WooCommerce Pre-Orders: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: WooCommerce Pre-Orders 2.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e72bbe9b-e51d-40ab-820d-404e0cb86ee6
- https://wpscan.com/vulnerability/e72bbe9b-e51d-40ab-820d-404e0cb86ee6
Get alerted when CVE-2023-3507 or the next vulnerability affects your stack