What’s Vulnerable › Vulnerabilities
CVE-2023-3508: WooCommerce Pre-Orders < 2.0.3 - Unauthorised Actions via CSRF
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-31 · updated 2026-06-17
Description
The WooCommerce Pre-Orders WordPress plugin before 2.0.3 has a flawed CSRF check when processing its tab actions, which could allow attackers to make logged in admins email pre-orders customer, change the released date, mark all pre-orders of a specific product as complete or cancel via CSRF attacks
Affected products
- WooCommerce Pre-Orders: before 2.0.3 — fixed in 2.0.3
How to fix
Upgrade to a fixed version: WooCommerce Pre-Orders 2.0.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/064c7acb-db57-4537-8a6d-32f7ea31c738
- https://wpscan.com/vulnerability/064c7acb-db57-4537-8a6d-32f7ea31c738
Get alerted when CVE-2023-3508 or the next vulnerability affects your stack