What’s Vulnerable › Vulnerabilities

CVE-2023-3511: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 8.17 before 16.4.4, all versions starting from 16.5 before 16.5.4, all versions starting from 16.6 before 16.6.2. It was possible for auditor users to fork and submit merge requests to private projects they're not a member of.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.4.4, 16.5.4, 16.6.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-3511 or the next vulnerability affects your stack