What’s Vulnerable › Vulnerabilities

CVE-2023-35133: Moodle: ssrf risk due to insufficient check on the curl blocked hosts

Description

An issue in the logic used to check 0.0.0.0 against the cURL blocked hosts lists resulted in an SSRF risk. This flaw affects Moodle versions 4.2, 4.1 to 4.1.3, 4.0 to 4.0.8, 3.11 to 3.11.14, 3.9 to 3.9.21 and earlier unsupported versions.

Affected products

How to fix

Upgrade to a fixed version: Moodle 3.11.15, 3.9.22, 4.0.9, 4.1.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-35133 or the next vulnerability affects your stack