What’s Vulnerable › Vulnerabilities
CVE-2023-35141
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-14 · updated 2026-06-17
- Weakness: CWE-352
Description
In Jenkins 2.399 and earlier, LTS 2.387.3 and earlier, POST requests are sent in order to load the list of context actions. If part of the URL includes insufficiently escaped user-provided values, a victim may be tricked into sending a POST request to an unexpected endpoint by opening a context menu.
Affected products
- Jenkins: before 2.400; before 2.401.1 — fixed in 2.400, 2.401.1
How to fix
Upgrade to a fixed version: Jenkins 2.400, 2.401.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/06/14/5
- https://www.jenkins.io/security/advisory/2023-06-14/#SECURITY-3135
- http://www.openwall.com/lists/oss-security/2023/06/14/5
- https://www.jenkins.io/security/advisory/2023-06-14/#SECURITY-3135
Get alerted when CVE-2023-35141 or the next vulnerability affects your stack