What’s Vulnerable › Vulnerabilities
CVE-2023-35150: XWiki Platform vulnerable to privilege escalation (PR) from view right via Invitation application
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 77.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-95
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Starting in version 2.40m-2 and prior to versions 14.4.8, 14.10.4, and 15.0, any user with view rights on any document can execute code with programming rights, leading to remote code execution by crafting an url with a dangerous payload. The problem has been patched in XWiki 15.0, 14.10.4 and 14.4.8.
Affected products
- xwiki-platform: from 2.5 before 14.4.8; from 14.10 before 14.10.4; 2.4-milestone2 — fixed in 14.10.4, 14.4.8
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.4, 14.4.8. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/b65220a4d86b8888791c3b643074ebca5c089a3a
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-6mf5-36v9-3h2w
- https://jira.xwiki.org/browse/XWIKI-20285
- https://github.com/xwiki/xwiki-platform/commit/b65220a4d86b8888791c3b643074ebca5c089a3a
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-6mf5-36v9-3h2w
- https://jira.xwiki.org/browse/XWIKI-20285
Get alerted when CVE-2023-35150 or the next vulnerability affects your stack