What’s Vulnerable › Vulnerabilities
CVE-2023-35154: Knowage-Server vulnerable to account validation bypass
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-287
Description
Knowage is an open source analytics and business intelligence suite. Starting in version 6.0.0 and prior to version 8.1.8, an attacker can register and activate their account without having to click on the link included in the email, allowing them access to the application as a normal user. This issue has been patched in version 8.1.8.
Affected products
- KnowageLabs Knowage-Server: from 6.1.0 before 8.1.8 — fixed in 8.1.8
How to fix
Upgrade to a fixed version: KnowageLabs Knowage-Server 8.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-48hp-jvv8-cf62
- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-48hp-jvv8-cf62
Get alerted when CVE-2023-35154 or the next vulnerability affects your stack