What’s Vulnerable › Vulnerabilities
CVE-2023-35157: XWiki Platform vulnerable to reflected cross-site scripting via delattachment action
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. It's possible to perform an XSS by forging a request to a delete attachment action with a specific attachment name. Now this XSS can be exploited only if the attacker knows the CSRF token of the user, or if the user ignores the warning about the missing CSRF token. The vulnerability has been patched in XWiki 15.1-rc-1 and XWiki 14.10.6.
Affected products
- xwiki-platform: before 14.10.6; 15.0 — fixed in 14.10.6
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.6. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/35e9073ffec567861e0abeea072bd97921a3decf
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-phwm-87rg-27qq
- https://jira.xwiki.org/browse/XWIKI-20339
- https://github.com/xwiki/xwiki-platform/commit/35e9073ffec567861e0abeea072bd97921a3decf
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-phwm-87rg-27qq
- https://jira.xwiki.org/browse/XWIKI-20339
Get alerted when CVE-2023-35157 or the next vulnerability affects your stack