What’s Vulnerable › Vulnerabilities
CVE-2023-35162: XPlatform Wiki vulnerable to cross-site scripting via xcontinue parameter in preview actions template
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-79
Description
XWiki Platform is a generic wiki platform offering runtime services for applications built on top of it. Users are able to forge an URL with a payload allowing to inject Javascript in the page (XSS). It's possible to exploit the previewactions template to perform a XSS, e.g. by using URL such as: > <hostname>/xwiki/bin/get/FlamingoThemes/Cerulean xpage=xpart&vm=previewactions.vm&xcontinue=javascript:alert(document.domain). This vulnerability exists since XWiki 6.1-rc-1. The vulnerability has been patched in XWiki 14.10.5 and 15.1-rc-1.
Affected products
- xwiki-platform: from 6.2 before 14.10.5; 6.1, 6.1-milestone1, 6.1-milestone2, 6.1-rc1 — fixed in 14.10.5
How to fix
Upgrade to a fixed version: xwiki-platform 14.10.5. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/9f01166b1a8ee9639666099eb5040302df067e4d
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-q9hg-9qj2-mxf9
- https://jira.xwiki.org/browse/XWIKI-20342
- https://jira.xwiki.org/browse/XWIKI-20583
- https://github.com/xwiki/xwiki-platform/commit/9f01166b1a8ee9639666099eb5040302df067e4d
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-q9hg-9qj2-mxf9
- https://jira.xwiki.org/browse/XWIKI-20342
- https://jira.xwiki.org/browse/XWIKI-20583
Get alerted when CVE-2023-35162 or the next vulnerability affects your stack