What’s Vulnerable › Vulnerabilities
CVE-2023-35165: AWS CDK EKS overly permissive trust policies
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-23 · updated 2026-06-17
- Weakness: CWE-863
Description
AWS Cloud Development Kit (AWS CDK) is an open-source software development framework to define cloud infrastructure in code and provision it through AWS CloudFormation. In the packages `aws-cdk-lib` 2.0.0 until 2.80.0 and `@aws-cdk/aws-eks` 1.57.0 until 1.202.0, `eks.Cluster` and `eks.FargateCluster` constructs create two roles, `CreationRole` and `default MastersRole`, that have an overly permissive trust policy. The first, referred to as the `CreationRole`, is used by lambda handlers to create the cluster and deploy Kubernetes resources (e.g `KubernetesManifest`, `HelmChart`, ...) onto it. Users with CDK version higher or equal to 1.62.0 (including v2 users) may be affected. The second, referred to as the `default MastersRole`, is provisioned only if the `mastersRole` property isn't provided and has permissions to execute `kubectl` commands on the cluster. Users with CDK version higher or equal to 1.57.0 (including v2 users) may be affected. The issue has been fixed in `@aws-cdk/aws-eks` v1.202.0 and `aws-cdk-lib` v2.80.0. These versions no longer use the account root principal. Instead, they restrict the trust policy to the specific roles of lambda handlers that need it. There is no workaround available for CreationRole. To avoid creating the `default MastersRole`, use the `mastersRole` property to explicitly provide a role.
Affected products
- aws-cdk: from 1.57.0 before 1.202.0; from 2.0.0 before 2.80.0 — fixed in 1.202.0, 2.80.0
How to fix
Upgrade to a fixed version: aws-cdk 1.202.0, 2.80.0. Check the vendor advisory for mitigations.
References
- https://github.com/aws/aws-cdk/issues/25674
- https://github.com/aws/aws-cdk/security/advisories/GHSA-rx28-r23p-2qc3
- https://github.com/aws/aws-cdk/issues/25674
- https://github.com/aws/aws-cdk/security/advisories/GHSA-rx28-r23p-2qc3
Get alerted when CVE-2023-35165 or the next vulnerability affects your stack