What’s Vulnerable › Vulnerabilities
CVE-2023-35168: DataEase has a privilege bypass vulnerability
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-26 · updated 2026-06-17
- Weakness: CWE-732
Description
DataEase is an open source data visualization analysis tool to analyze data and gain insight into business trends. Affected versions of DataEase has a privilege bypass vulnerability where ordinary users can gain access to the user database. Exposed information includes md5 hashes of passwords, username, email, and phone number. The vulnerability has been fixed in v1.18.8. Users are advised to upgrade. There are no known workarounds for the vulnerability.
Affected products
- dataease: before 1.18.8 — fixed in 1.18.8
How to fix
Upgrade to a fixed version: dataease 1.18.8. Check the vendor advisory for mitigations.
References
- https://github.com/dataease/dataease/security/advisories/GHSA-c2r2-68p6-73xv
- https://github.com/dataease/dataease/security/advisories/GHSA-c2r2-68p6-73xv
Get alerted when CVE-2023-35168 or the next vulnerability affects your stack