What’s Vulnerable › Vulnerabilities
CVE-2023-35701: Apache Hive: Arbitrary command execution via JDBC driver
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Hive. The vulnerability affects the Hive JDBC driver component and it can potentially lead to arbitrary code execution on the machine/endpoint that the JDBC driver (client) is running. The malicious user must have sufficient permissions to specify/edit JDBC URL(s) in an endpoint relying on the Hive JDBC driver and the JDBC client process must run under a privileged user to fully exploit the vulnerability. The attacker can setup a malicious HTTP server and specify a JDBC URL pointing towards this server. When a JDBC connection is attempted, the malicious HTTP server can provide a special response with customized payload that can trigger the execution of certain commands in the JDBC client.This issue affects Apache Hive: from 4.0.0-alpha-1 before 4.0.0. Users are recommended to upgrade to version 4.0.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache Hive: 4.0.0-alpha1, 4.0.0-alpha2, 4.0.0-beta1
References
- http://www.openwall.com/lists/oss-security/2024/05/03/3
- https://lists.apache.org/thread/7zcv6l63spl4r66xwz5jv9rtrg2opx81
- http://www.openwall.com/lists/oss-security/2024/05/03/3
- https://lists.apache.org/thread/7zcv6l63spl4r66xwz5jv9rtrg2opx81
Get alerted when CVE-2023-35701 or the next vulnerability affects your stack