What’s Vulnerable › Vulnerabilities
CVE-2023-35721: NETGEAR Multiple Routers curl_post Improper Certificate Validation Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-295
Description
NETGEAR Multiple Routers curl_post Improper Certificate Validation Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to compromise the integrity of downloaded information on affected installations of multiple NETGEAR routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the update functionality, which operates over HTTPS. The issue results from the lack of proper validation of the certificate presented by the server. An attacker can leverage this in conjunction with other vulnerabilities to execute arbitrary code in the context of root. Was ZDI-CAN-19981.
Affected products
- NETGEAR Rax50 Firmware: before 1.0.15.128 — fixed in 1.0.15.128
How to fix
Upgrade to a fixed version: NETGEAR Rax50 Firmware 1.0.15.128. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065668/Security-Advisory-for-Improper-Remote-Server-Certificate-Validation-on-the-RAX50-PSV-2023-0019
- https://www.zerodayinitiative.com/advisories/ZDI-23-893/
- https://kb.netgear.com/000065668/Security-Advisory-for-Improper-Remote-Server-Certificate-Validation-on-the-RAX50-PSV-2023-0019
- https://www.zerodayinitiative.com/advisories/ZDI-23-893/
Get alerted when CVE-2023-35721 or the next vulnerability affects your stack