What’s Vulnerable › Vulnerabilities
CVE-2023-35722: NETGEAR RAX30 UPnP Command Injection Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-78
Description
NETGEAR RAX30 UPnP Command Injection Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR RAX30 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of UPnP port mapping requests. The issue results from the lack of proper validation of a user-supplied string before using it to execute a system call. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-20429.
Affected products
- NETGEAR RAX30: before 1.0.11.96_2_hotfix — fixed in 1.0.11.96_2_hotfix
How to fix
Upgrade to a fixed version: NETGEAR RAX30 1.0.11.96_2_hotfix. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065699/Security-Advisory-for-Pre-Authentication-Command-Injection-on-the-RAX30-PSV-2023-0046
- https://www.zerodayinitiative.com/advisories/ZDI-23-894/
- https://kb.netgear.com/000065699/Security-Advisory-for-Pre-Authentication-Command-Injection-on-the-RAX30-PSV-2023-0046
- https://www.zerodayinitiative.com/advisories/ZDI-23-894/
Get alerted when CVE-2023-35722 or the next vulnerability affects your stack