What’s Vulnerable › Vulnerabilities
CVE-2023-3577: Limited blind SSRF to localhost/intranet in interactive dialog implementation
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-17 · updated 2026-06-17
- Weakness: CWE-918
Description
Mattermost fails to properly restrict requests to localhost/intranet during the interactive dialog, which could allow an attacker to perform a limited blind SSRF.
Affected products
- Mattermost: from 7.8.0 before 7.8.7; from 7.10.0 before 7.10.3 — fixed in 7.10.3, 7.8.7
How to fix
Upgrade to a fixed version: Mattermost 7.10.3, 7.8.7. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-3577 or the next vulnerability affects your stack