What’s Vulnerable › Vulnerabilities
CVE-2023-35788
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-16 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in fl_set_geneve_opt in net/sched/cls_flower.c in the Linux kernel before 6.3.7. It allows an out-of-bounds write in the flower classifier code via TCA_FLOWER_KEY_ENC_OPTS_GENEVE packets. This may result in denial of service or privilege escalation.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 20.04, 22.04
- Debian Linux: 12.0, 10.0, 11.0
- Linux kernel: from 4.19 before 4.19.285; from 4.20 before 5.4.246; from 5.5 before 5.10.183; from 5.11 before 5.15.116; from 5.16 before 6.1.33; from 6.2 before 6.3.7 — fixed in 4.19.285, 5.10.183, 5.15.116, 5.4.246, 6.1.33, 6.3.7
- NetApp H300S Firmware: all versions
- NetApp H410C Firmware: all versions
- NetApp H410S Firmware: all versions
- NetApp H500S Firmware: all versions
- NetApp H700S Firmware: all versions
How to fix
Upgrade to a fixed version: Linux kernel 4.19.285, 5.10.183, 5.15.116, 5.4.246. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/174577/Kernel-Live-Patch-Security-Notice-LSN-0097-1.html
- http://www.openwall.com/lists/oss-security/2023/06/17/1
- https://cdn.kernel.org/pub/linux/kernel/v6.x/ChangeLog-6.3.7
- https://git.kernel.org/linus/4d56304e5827c8cc8cc18c75343d283af7c4825c
- https://lists.debian.org/debian-lts-announce/2023/07/msg00030.html
- https://lists.debian.org/debian-lts-announce/2023/10/msg00027.html
- https://security.netapp.com/advisory/ntap-20230714-0002/
- https://www.debian.org/security/2023/dsa-5448
- https://www.debian.org/security/2023/dsa-5480
- https://www.openwall.com/lists/oss-security/2023/06/07/1
- http://packetstormsecurity.com/files/174577/Kernel-Live-Patch-Security-Notice-LSN-0097-1.html
- http://www.openwall.com/lists/oss-security/2023/06/17/1
Get alerted when CVE-2023-35788 or the next vulnerability affects your stack