What’s Vulnerable › Vulnerabilities
CVE-2023-35790
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-16 · updated 2026-06-17
- Weakness: CWE-191
Description
An issue was discovered in dec_patch_dictionary.cc in libjxl before 0.8.2. An integer underflow in patch decoding can lead to a denial of service, such as an infinite loop.
Affected products
- libjxl: before 0.8.2 — fixed in 0.8.2
How to fix
Upgrade to a fixed version: libjxl 0.8.2. Check the vendor advisory for mitigations.
References
- https://github.com/libjxl/libjxl/pull/2551
- https://github.com/libjxl/libjxl/releases/tag/v0.8.2
- https://github.com/libjxl/libjxl/pull/2551
- https://github.com/libjxl/libjxl/releases/tag/v0.8.2
Get alerted when CVE-2023-35790 or the next vulnerability affects your stack