What’s Vulnerable › Vulnerabilities
CVE-2023-35797: Apache Airflow Hive Provider Beeline RCE with Principal
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-03 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper Input Validation vulnerability in Apache Software Foundation Apache Airflow Hive Provider. This issue affects Apache Airflow Apache Hive Provider: before 6.1.1. Before version 6.1.1 it was possible to bypass the security check to RCE via principal parameter. For this to be exploited it requires access to modifying the connection details. It is recommended updating provider version to 6.1.1 in order to avoid this vulnerability.
Affected products
- Apache Software Foundation Apache Airflow Hive Provider: before 6.1.1 — fixed in 6.1.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Airflow Hive Provider 6.1.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/07/12/3
- https://github.com/apache/airflow/pull/31983
- https://lists.apache.org/thread/30y19ok07fw52x5hnkbhwqo3ho0wwc1y
- http://www.openwall.com/lists/oss-security/2023/07/12/3
- https://github.com/apache/airflow/pull/31983
- https://lists.apache.org/thread/30y19ok07fw52x5hnkbhwqo3ho0wwc1y
Get alerted when CVE-2023-35797 or the next vulnerability affects your stack