What’s Vulnerable › Vulnerabilities
CVE-2023-35833
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-13 · updated 2026-06-17
- Weakness: CWE-319
Description
An issue was discovered in YSoft SAFEQ 6 Server before 6.0.82. When modifying the URL of the LDAP server configuration from LDAPS to LDAP, the system does not require the password to be (re)entered. This results in exposing cleartext credentials when connecting to a rogue LDAP server. NOTE: the vendor originally reported this as a security issue but then reconsidered because of the requirement for Admin access in order to change the configuration.
Affected products
- YSoft Safeq Server: from 6.0 before 6.0.82 — fixed in 6.0.82
How to fix
Upgrade to a fixed version: YSoft Safeq Server 6.0.82. Check the vendor advisory for mitigations.
References
- https://www.ysoft.com/en/legal/ldaps-encryption-downgrade-attack-vulnerability
- https://ysoft.com
- https://www.ysoft.com/en/legal/ldaps-encryption-downgrade-attack-vulnerability
- https://ysoft.com
Get alerted when CVE-2023-35833 or the next vulnerability affects your stack