What’s Vulnerable › Vulnerabilities
CVE-2023-35844
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-06-19 · updated 2026-06-17
- Weakness: CWE-22
Description
packages/backend/src/routers in Lightdash before 0.510.3 has insecure file endpoints, e.g., they allow .. directory traversal and do not ensure that an intended file extension (.csv or .png) is used.
Affected products
- lightdash: before 0.510.3 — fixed in 0.510.3
How to fix
Upgrade to a fixed version: lightdash 0.510.3. Check the vendor advisory for mitigations.
References
- https://advisory.dw1.io/59
- https://github.com/lightdash/lightdash/commit/fcc808c84c2cc3afb343063e32a49440d32a553c
- https://github.com/lightdash/lightdash/compare/0.510.2...0.510.3
- https://github.com/lightdash/lightdash/pull/5090
- https://advisory.dw1.io/59
- https://github.com/lightdash/lightdash/commit/fcc808c84c2cc3afb343063e32a49440d32a553c
- https://github.com/lightdash/lightdash/compare/0.510.2...0.510.3
- https://github.com/lightdash/lightdash/pull/5090
Get alerted when CVE-2023-35844 or the next vulnerability affects your stack