What’s Vulnerable › Vulnerabilities
CVE-2023-35908: Apache Airflow: Access to DAGs without relevant permission
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-863
Description
Apache Airflow, versions before 2.6.3, is affected by a vulnerability that allows unauthorized read access to a DAG through the URL. It is recommended to upgrade to a version that is not affected
Affected products
- Apache Airflow: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: Apache Airflow 2.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/apache/airflow/pull/32014
- https://lists.apache.org/thread/vsflptk5dt30vrfggn96nx87d7zr6yvw
- https://github.com/apache/airflow/pull/32014
- https://lists.apache.org/thread/vsflptk5dt30vrfggn96nx87d7zr6yvw
Get alerted when CVE-2023-35908 or the next vulnerability affects your stack