What’s Vulnerable › Vulnerabilities
CVE-2023-35916: WordPress WooCommerce Payments Plugin <= 5.9.0 is vulnerable to Insecure Direct Object References (IDOR)
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-20 · updated 2026-06-17
- Weakness: CWE-639
Description
Authorization Bypass Through User-Controlled Key vulnerability in Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo.This issue affects WooPayments – Fully Integrated Solution Built and Supported by Woo: from n/a through 5.9.0.
Affected products
- Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo: before 5.9.1 — fixed in 5.9.1
How to fix
Upgrade to a fixed version: Automattic WooPayments – Fully Integrated Solution Built and Supported by Woo 5.9.1. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/woocommerce-payments/wordpress-woocommerce-payments-plugin-5-9-0-insecure-direct-object-references-idor-vulnerability?_s_id=cve
- https://patchstack.com/database/vulnerability/woocommerce-payments/wordpress-woocommerce-payments-plugin-5-9-0-insecure-direct-object-references-idor-vulnerability?_s_id=cve
Get alerted when CVE-2023-35916 or the next vulnerability affects your stack