What’s Vulnerable › Vulnerabilities
CVE-2023-35926: Insecure sandbox in Backstage Scaffolder plugin
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-06-22 · updated 2026-06-17
- Weakness: CWE-94
Description
Backstage is an open platform for building developer portals. The Backstage scaffolder-backend plugin uses a templating library that requires sandbox, as it by design allows for code injection. The library used for this sandbox so far has been `vm2`, but in light of several past vulnerabilities and existing vulnerabilities that may not have a fix, the plugin has switched to using a different sandbox library. A malicious actor with write access to a registered scaffolder template could manipulate the template in a way that allows for remote code execution on the scaffolder-backend instance. This was only exploitable in the template YAML definition itself and not by user input data. This is vulnerability is fixed in version 1.15.0 of `@backstage/plugin-scaffolder-backend`.
Affected products
- backstage: before 1.15.0 — fixed in 1.15.0
How to fix
Upgrade to a fixed version: backstage 1.15.0. Check the vendor advisory for mitigations.
References
- https://github.com/backstage/backstage/commit/fb7375507d56faedcb7bb3665480070593c8949a
- https://github.com/backstage/backstage/releases/tag/v1.15.0
- https://github.com/backstage/backstage/security/advisories/GHSA-wg6p-jmpc-xjmr
- https://github.com/backstage/backstage/commit/fb7375507d56faedcb7bb3665480070593c8949a
- https://github.com/backstage/backstage/releases/tag/v1.15.0
- https://github.com/backstage/backstage/security/advisories/GHSA-wg6p-jmpc-xjmr
Get alerted when CVE-2023-35926 or the next vulnerability affects your stack